Cant sign in to vital plus

Same,and I don’t know why.

1 Like

Yeah not quite sure why this is happening but I’m looking into this. Would be helpful to know people’s OS+version, country and if they’re using a VPN or not (or any other special internet setup).

The build that is coming out today won’t require signing in and you’ll be able to manually install the presets (usually after you sign in it auto downloads presets)


Sign in through the Standalone version and not the DAW. From there it will ask you where to download the presets. Thanks @Chaney for finding the fix.


Exact same thing happened with me… please resolve this issue possibly soon!

1 Like

Same here, Win 10 64
Free Version

I would assume that it’s because windows doesn’t trust the developer certificate. This program shouldn’t harm your computer in any way. I imagine Matt wouldn’t want to ruin his reputation that quickly :joy: BUT, if you get something like this with other programs, proceed with caution!:smiley:

Same with me on the pro version. I’m running Catalina.

First installed it on my laptop with MacOS Catalina 10.15.7 and no problem. Then tried it on my older desktop which runs MacOS Sierra 10.12.6 and got the problem mentioned above. Thought it’s because I run it on both systems. (Netherlands, no VPN)

the preset and wavetable download link would be handy as mine folders are currently empty

1 Like

no presets indeed

For anyone on Windows worried about the Windows Defender warning, that’s normal for brand new .exe installers that not many people have yet installed. Windows logs stuff like this and once it sees enough Windows user installing an .exe with a given certificate, it stops warning users about it.

Just click the “more info” link (or whatever) and tell Windows to install it anyway.

1 Like

Click next to the login window and the synth works.

1 Like

Sign in on the app first, not in a DAW to get presets!


I just wanted to let him know that this was happening and also to let others know that it’s not just them. This is pretty common when releasing a new build. You’re bound to have a few hickups along the way. It looks like though he’s going to have his hands full for the next few days possibly? To work out all the kinks. I’m gonna be hopeful and I look forward to when it does work. Thanks

I went to my system folder and ran the standalone version and it worked. I was able to sign in. It installed all the presets to a specified folder and they too work.

Run the Standalone Version and sign in from there.

Edit: In FL Studio, when added to a rack, it still shows up as sample and not Vital. Does anyone know how to fix that? I’m still new to FL… Thanks

Right Click on the sample to bring up this menu, and vital should be listed under “Instrument Synth”

If it’s not there you will either have to open the plugin picker, or add Vital to your favorites in the plugin manager. I can provide additional screenshots if needed.

1 Like

It doesn’t show up in the list. I had to go to more plugins and set it as a favorite but that worked. Thanks

1 Like

No problem, good luck!

1 Like

Login works in the standalone but still no wavetables or presets.

same problem