Can't Access Account/Download Page

I thought it must be my connection slowed down, but no. Then thought it might be a browser and-or OS problem, but no. On my MX Linux and Windows 11 machines I get the perpetual swirl barring access to download Vital. I even tried using the purchase link and got the same result.

Works for me. Using a VPN?

Why suggest normalizing the need for an extra step instead of addressing a problem that is not of my making?

Tried with VPN, the with VPN/Private Browsing with a different network access provider after completely flushing cookies and restarting the browser.
Same result after logging back in, I got the same result.

What I meant is that sometimes using VPN brings trouble, some services block VPN addresses.

Maybe try creating a dummy account to see if your account has some problem in the database.

1 Like

OK, that didn’t work either. New account on my MX Linux machine and still couldn’t download the free version. I can access the Preset part of the store, but not the application download.

This would suggest it’s a network issue. I’d try logging in and downloading somewhere else. If you can’t do it with a laptop, then maybe on a friend’s computer.

Strange that a vpn didn’t solve that though, even if you changed region there. But if that didn’t work with a vanilla browser installation on different browsers and accounts then I don’t really see what else could it be. Unless both of your accounts are fresh and there’s something wrong with new accounts.

I’m 67 and disabled, with no friends or family. Second, I switched to using my mobile hotspot (T-Mobile), which is a different network access than my building (Comcast), and got the same results. Third, it’s really frustrating to have been a long time, paid supporter, and can’t get the courtesy of Matt or whoever the helps him with site admin, to take a moment to look at the logs and see what is happening.

I don’t know why I’m surprised with this hassle, when I can’t even get basic requests like my account email updated.

Oh, hmm yes, Tytel isn’t the most responsive person. Have you tried getting him through Vital’s Discord? That’s probably the best way to get things done. It could be worth a shot to go there, on a supporter channel if you have an access to one or that all channel if not, and ask about this and link to this thread and tag Tytel in that message.

I’m sorry to hear about your situation and I hope tou get this sorted out.

1 Like

I copied everything I shared here in the Discord support channel. They said it was strange, but did send me a link, so I could download a copy. Not a long-term solution, but I’m good for now.


Nice one. Now if you have that Discord perk and you run into problems, it’d be better to go to a supporter channel or #all and try to get in touch with the dev directly. I imagine your Vital needs to dl and install some packs, but since you did connect to preset store those might dl just fine. Probably a good idea to keep a backup copy of the installer. That support channel is explicitly community driven, so no official support is given there I imagine.


I appear to have access to the forum, the preset store, but even with an entirely new account, no access to I was able to see it only once when I first created this new account, but never after that. The same on both Linux and Windows machines, and when I switched to Internet access via my phone’s hot spot, also the same result. It’s the kind of thing that when it happened in the past, turned out to be someone’s deliberate action.

Have you tried using a different Browser

1 Like

Duh, good point. Can’t believe I flushed cookies but didn’t think of that. OK, since Opera, Edge, and many others are all Chromium based, let me switch to Firefox.

Also If that doesn’t work can you access the downloads area on your phone?I just checked and I’m able to download vital on my iPhone. Then you could just transfer it to your computer or email it to yourself or whatever

Switching browsers worked. I assume the last Chromium core update caused a problem, since it affected Edge and Opera. Firefox works fine.

1 Like

Brave works too and it’s chromium

1 Like