Can someone wake me up when it works

can someone wake me up when it works we are now in version 1.05 the second update and it is even worse than 1.0.3 and 1.04 disco flashing version, can it please be made , before any improvement wishes are implemented, so I can finally do something so i can record !!

Works just fine here on two different systems and it works just fine for the majority of people. :wink:

How is it helpful just to complain to the developer without giving any details ? Are you on Windows ? Mac? Linux ? What version ?

What are your system specs ? Are you using the VST 2 or VST 3 version ?

You can complain or you can help find out why it’s not working…for YOU.

6 Likes

You could be nicer, too. You are being offered a synth, for free with full functionality. If it works for you, great. If not, then you are welcome to provide constructive feedback and/or resources (money) that help improving the software. Or you can use any other synth out there, and come back (if you wish) later.

This young project and community are so welcoming and helpful and nice to each other. Sit back and enjoy! Or at least give the developer some slack and appreciation.

6 Likes

i am using linux avlinux mxe, i am a pro vital user have nothing against matt and his
really nice synt helmet and this one even better, but I am not a beta tester and musician I can only work with it when it works, but after I have had two updates and the problems are not gone, I can still not use it okay the standalone version works .
in vital 1.0.5 lv2 and vst does not work in mixbus32c, vital 1.0.3 in this case unfortunately remains the best version in mixbus 32c and all praise matt i love to work with his wavetable synth i know all takes time, i wait, I’ll be back

2 Likes

Have you tried linux Reaper, Bitwig or qtractor? Mixbus is much better in 2020,
but without testing Vital on the others, your frame of reference is pretty narrow.
The above have free demos, but you’re a pro, so you know that, and might as well
take advantage of what’s available.

vital works badly in reaper (paid version) it boots up.
but if choose another screen, for another plug, crash
everything with the vsti and the vst3i, I don’t just use vital, but also other plugins, but I was hopeful with 1.0.4 disco flashing version didn’t work okay waited for 1.05 doesn’t work either
, and then I didn’t even mention .wave files that cannot be loaded, I don’t mind, everything takes time but every time I hope it works, after a new update, but no it doesn’t work I use my avlinux mxe (the new version) for testing, before the big switch from the avlinux OLD version

So you’ve learned the value of giving your system specs especially your OS when making a complaint.

As much as I love Linux (I have a dedicated Kubuntu system) I would not use it for making music.

There are too many Linux Distros for one developer to keep up with. I think Matt should probably have waited to release the Linux version. Just having to support the Windows and Mac versions is enough for one person for right now. Once those versions are issue free then he could move on to releasing the Linux version.

So yea Vital works fine here on two different systems…both running Windows 10. :wink:

1 Like

market-oriented thinking and your objectives are very understandable to the largest group of users.
Linux sounds very good music related, nice to play with
never nagging to work just keeps running, if I want something changed, then just can
was created by people with a heart for others, after my idea the right philosophy
I like to sponsor people who start with a good idea in which everyone grows
I’ve used Windows with Cubase etc for years, I thought Windows was a horror! never work after expectations there was always something, they do not determine the user and cost quite a lot of money! After a few years you can throw away all your hardware because it will no longer be supported, a waste machine and that in this time, I switched years ago, Linux feels like a warm jacket in this cold world
and all the money I save goes after people who develop something that everyone can or count with. if you know what I mean.
but this is clarity here I can do something whit (Teksonic) half a year from now
come and have a look,

I have no idea what you’re trying to say. I love Linux too but just not for making music. There just isn’t enough support yet and by your own admission things don’t “just work” all the time.

The fact that I have Vital running just fine on my Windows systems and you don’t on your Linux system is proof enough for me.

i don’t write English as well as you but i think
it’s a shame that Linux isn’t supported as windows
waste machine, i hope so but market oriented i understand,
and teksonik you really make me laugh

@vicee it is not a shame and i don´t think it has to do much with market, the point is there are many linux distributions and only one windows. It´s just a lot more work.

if it makes you laugh when people are trying to help you, maybe it´s the best to just ignore you.

Please - no more OS flame wars - it’s so tedious.

Matt is offering a Linux version. People use it / buy it. If it doesn’t work, then they should flag it here. Matt can say if that particular distro isn’t supported. It’s clearly quite complicated to support, but it’s his gig.

Sure, the tone of the OP was a bit negative, but probably reflects some frustration.

Let’s move on :slight_smile:

1 Like

Yeah let’s keep things on topic. Plenty of other places on the internet to argue about OS’s.

To respond to the OP, on the site it lists that only “Ubuntu Linux 18.04 and above” is supported. I’ll make an effort to support other linux distros but any issues on Ubuntu variants take precedence. The flashing may have to do with what graphics card and drivers you are using so any information there would help.

Another thing, Reaper’s linux build is marked as “experimental” so it’s quite possible there’s an issue on that side. If there’s an issue across DAWs, let me know but if it’s Reaper specific you may want to report it to them.

2 Likes

The question for me is have you demonstrated the GUI to work properly for the LV2 version on said version of Ubuntu? I can work around most platform differences, but this seems as if it may be a problem in JUCE. I think I sent you a note to that effect with some links. Have you had the opportunity to check any of this out?

1 Like

Ok to stay positive, when i put ubuntu 20.10, vital 1.0.5 and reaper 6.20 to an usb stick everything runs fine here. Can test it on 18.04 too, if this info helps to track down the problem.

The OP has posted he is using AVLinux MXE which is based on MX Linux which is based on Debian as is Ubuntu.

Perhaps there will be some useful information about the distro in this link. It does list the Kernel version:

By “everything” do you mean that you have run the Vital.lv2 plugin successfully from an LV2 host such as QTractor, jalv.gtk, Carla, or Ardour? This particular aspect matters much to me as I run LV2s with a heavily customized host which I use in developing custom performance hardware. I do not care about VST3 or standalone support. To remove all doubt, I’m asking specifically about LV2 support. If you run it as a standalone or a VST3, that doesn’t answer any questions about LV2.

These are the links I sent to Matt:


couldn´t figure out how to run/install qtractor or ardour. but i can try again if you give me some advice how to make them run.

sorry for the late response I am at work, but these are my data

AVLINUX-MXE ASUS p9x79 – i7 3820 32gb amd boniar 2.50.0,5.9.1 rt20avl1, llvm 7.01
(AMD r7 260x) REAPER MIBUS 32C