Basic Shapes Waveform does not blend

Howdy! I am having an issue with my basic shapes waveform not blending smoothly, just shows abruptly switching. Any suggestions on this?I did download vital again and still not working correctly!

Thanks,

Corey M

same here
i assume it’s the supposed behaviour
in the FACTORY wavetable collection try “Classic Fade” or “Classic Blend”
those blend smoothly through various wave shapes

or have a look at other vendor’s wavetables
there are tons and also tons of basic waveshapes that blend…

hth

Not sure if you mean in general or in the wavetable editor but I also can’t get basic shapes to blend, spectral or crossfade. Maybe I misunderstood and am not doing the wavetable editor correctly.
Otherwise the table Basic Shapes itself, yes, switches from shape to shape with no blend.

If you want to blend set “NONE” to “Waveform blend”

in the editor. (click the pencil in the waveform)

Yeah Yeager adjusting does not blend for me, waveform or spectral - the table remains the same.

Just to be sure you are trying to blend( morph) from one wave to another like this :

Moving from frame to frame.

When it’s set to none it skips from one to another, if set to “waveform blend” it should morph from one to another.

BTW the table should not change only the behaviour.

1 Like

Yeah exactly, wasn’t blending at all for me.
Will try again when I’m back at home, it’s probably just me lol

1 Like

Nah its not just you, I used all the blend types and still does not smoothly blend, it just does it fast and popy lol

afbeelding
afbeelding

There is a slight difference when none (top) or waveform blend (bottom) is used.

I’m on Windows 10 Vital 1.5.5.

does not work here either
i set it to blend, fade, spectral, special…whatevver
i selected individual keyframes, more, all, none
i clicked selected blend for each and every (thinking maybe the display is lacking…)

nada

anybody knows how this wave editor is working ???

this must be doable somehow…

I just select Basic Shapes in the OSC , click the pencil, click on none, select “Waveform Blend” click on the X in the top right corner and I’m done.

i am doing exactly these steps:
still not fading/blending (but steppy, non interpolating switching)

Same as the instructions provided, it doesnt change anything, I am using ableton with mac. Not sure if that helps but hopefully we can get a ticket submitted!

basic shapes is a Wave Source and the other more “blendy” wavetables are “Audio File Source”, could that have something to do with it? maybe the basic shapes has fewer frames in it than are necessary for interpolation or something.

was also my thought yesterday but for example “Classic Fade” is also a “wave source” type and interpolates-blend perfectly…

…and, thanks to this thread (at least it was good for something) i began to look more into the wavetable editor, and its actually quite simple to build your own “basci shapes blender table”, which in all incarnations blend quite well

intersting:
with wave source it doesn’t matter if there is “none” or “waveform blend” or whatever is selected…
(at least here…)

…which brings to the table:
why and how do some wavtable preset not interpolate ?

and yes:
an official manual would be useful…

i just tried resynthesizing the basic shapes, using a stepped modulation, and the result also kind of “jumps” between wave shapes, and i think it is due to the lookahead windowing in the interpolation. too much lookahead then there would be a loss in resolution of frames, but since there’s nothing going on but 7 or so static shapes, there’s nothing to interpolate most of the time so the wave just stands there, a square wave that’s 30 frames long is only fading into a square wave for ‘quite a while’ so there’s not enough advance data to suggest what to interpolate into. i don’t really see or intuit a way to alter the “lookahead/lookbehind” windowing width of the wave-blend interpolation algorithm to offer any further insight.

Works here. Can someone whose isn’t working post a screenshot of what exactly you’re clicking on…?

1 Like

Are you using the latest version?
There was such a bug in previous versions.
Please try to download again.

I didn’t think to click on the word ‘none’ to get the dropdown menu, great tip/reminder.

I was able to get mine to work, but it was after downloading it again, and rebooting the system. Things seem to work so far so good! Cheers!
Till the next bug lol Thanks yall!

1 Like