Ardour 6.7 and Vital

Hi all!

This is my first post here.
First I’d like to thank Mat Tytel for this exceptional synth. It is modern, easy to program and has limitless capabilities and a fair amount of presets.

First some specs:
I run Ubuntu Linux 21.04 (the latest version)
My computer is an Asus ROG GL552VW laptop with an i7 6700HQ CPU and NVIDIA GTX 960M GPU

Now to the point:
I strongly believe that top class developers like Mat must be rewarded for their hard effort. So, without any thought, I went on and bought the Pro Version of Vital (the latest one is 1.08). I also purchased the latest version of Ardour (6.7) wich is by far my favorite DAW.

And here the trouble starts…
While i can use the standalone Vital, none of the vst’s (vst2 or vst3) and lv2 plugins are detected by Ardour. I’ve searched this forum and also the ardour forum and I already know that the problem is that Vital is NOT statically linked with some libraries. I believe that the library that causes the problem in my case is libcurl3-gnutls.so

So if Mat @Tytel is reading this… Please Mat, push a statically linked version of Vital ASAP. This is urgent and of the highest priority. There is no point of trying and fixing all the bugs now. This can be done in due time.
Right now, I’ve paid for a marvelous synth that I just CAN’T USE !

Thank you advance

1 Like

I thought the libcurl issues were only in Arch based distros. Vital in ubuntu should work fine.

Do you have other VSTs that load correctly in Ardour? Can you make sure the the Vital VST is installed along side those? I think you can browse for a plugin to open in Ardour, what happens when you try and open it directly?

Also just to make sure, you installed with the .deb file right? (not the .zip)

1 Like

Hi Mat, and thank you for your immediate reply!

  1. Yes. Any other vst2 or vst3 is loaded correctly including Surge, Zebralette, TyrellN6, Ob-xd, Podolski , TAL Noisemaker ZynAddSubFx and of course Helm (lv2 version). Effects are also loaded properly.

  2. I have tried both the generic Linux version (.zip) under the directories ~/.vst and ~/vst3 and the deb specific package. None of them worked.

  3. vital vst doesn’t appear in the plugin list.

PS The problem occurs only when I use the official purchased version of Ardour (6.7 the latest one) from ardour.org . If I use the version of Ardour that comes with Ubuntu , everything works. But the Ubuntu version is already outdated has some bugs, and is not gonna change even in the next major version of Ubuntu. These bugs are fixed in the official version… That’s why I want to use this one.

Again, thank you so much Mat

1 Like