Ableton Live 11 Windows - MW/PB/Pressure not working (Vital 1.08)

With Vital 1.08 in Ableton Live 11 for Windows (v11.0), Mod, Pitch-Bend, and Pressure from my device don’t have any effect when assigned to controls.

The Mod and Pitch-Bend wheel graphics at the bottom-left will move correspondingly, but the little green dot on the left of the “drag-from” modulator squares doesn’t budge and the neither do the controls they are assigned to. As an example, in the attached pic I have the modulators assigned at full level to OSC1’s Level, Pan, and Wavetable position and I am attempting to activate them all at the same time from my device (you can see that the Mod-wheel graphic is pinned to the top), but there’s no response otherwise.

(Curiously, if I manually drag the Mod-wheel or Pitch-bend graphic in the Vital GUI with my mouse, it does affect the assigned controls.)

This all works fine in the last Ableton Live 10 and the latest Reaper, so it seems specific to Live 11.

I’ve tried turning off Vital updates and selecting “work offline” as well as disabling the vst3 version of Vital, alas with no improvement.

What are your midi channel settings for the vital channelstrip? Anything MPE like activated in Live11?

MPE is turned off for all the devices. I just tried enabling MPE on them and it made no difference to the issue.
MIDI is set to All Channels on the channel strip. As you can see in the pic, the MIDI Monitor plugin shows that the controller data is being received and the little green dots beside the modulator “drag” squares are are lighting in response, just not moving anywhere (and the graphic of the mod-wheel and Pitch-bend are moving - as mentioned). So, the data is getting into Vital - it’s just not able to utilize the values properly at a certain point in the code with this new version of Live it seems.

I tried a few other plugins and they are responding as expected to the MW,PB, and Pressure data. So it does seem specific to Vital.

BTW, kudos, Tytel, for all your efforts and making this fantastic synth accessible to all.

Yeah, well Live has been notorious in the past for making funny things with midi…and if the same version of Vital works fine in Live 10 as you wrote that points to an issue within Live or at least a peculiarity that makes vital misbehave.

As for the moving PB wheel in Vital that does nothing to the sound, but works when moved with the mouse… Well I get that exact behaviour when I play with an MPE instrument on a non MPE patch in vital. The wheel moves but the sound does not change. My guess is, that the graphics are tied to all midi channels while the sound only reacts if it is on the same channel as the note you play. Unless you are in MPE Mode.

So my guesses are:

-Live 11 somehow moves your PB and MW to a different channel before it reaches vital.

-Vital only responds to PB and MW on the same channel as incoming notes

Can you try and enable MPE in Vital (Advanced Tab) and see if you receive it now?

“Live 11 somehow moves your PB and MW to a different channel before it reaches vital”

As you can see in the pic with the Midi Monitor plugin before Vital, all the data is coming in on Channel 1 into Vital (including note data, even though none is shown in the pic).

“Can you try and enable MPE in Vital (Advanced Tab) and see if you receive it now?”

Good suggestion, this made a difference. With MPE Enabled in Vital, the Pitch-Bend and Pressure worked. Mod-wheel, still no go I’m afraid. So it does seem related to the MPE.

I’m not using and don’t yet own an MPE device but I can say that it seems to make no difference enabling it in the Ableton Live MIDI preferences for any of my devices or not in regards to results.

Ok, that is a start. I guess @Tytel will have to take it from there since I don’t use Live anymore (for the midi stuff that bothered me too much)

What is the MPE writing in the Vital representation in the Live chain at the bottom? Do all virtual instruments have that? Can you click the symbol there? Sorry, as I said I don’t use Live anymore :slight_smile:

I think the “MPE” label at the top of the plugin in the chain-view denotes that it is MPE-capable. It shows up on Serum and Ableton’s Wavetable synth and a few other MPE-capable plugs but none of the others.

Lokki, thanks for your help sussing this out.

Ok, so maybe Live wrongly assumes Vital is in MPE mode. This would explain the behaviour…

I would also not trust the Live midi Monitor, the chain might as well do something funky to the Midstream once it detects an MPE Plugin down the line.

A bit more info, @Tytel
Serum has an “MPE Enabled” setting (and shows up with the MPE-capable moniker regardless of how this is set in the plugin). MW, PB, and Pressure in Serum appears to be working as expected in Live 11 whether MPE is enabled or not in the plugin.

fyi: Tested out the Arturia Pigments 2 (MPE-capable) demo plugin in Live 11. It also seems to play well with Live 11 and MW,PB, and Pressure whether MPE is enabled or disabled in the plugin. So it’s looking more an more like a Vital issue.

1 Like

Hi,
yes, the problem is, that Ableton 11 recognizes Vital as MPE enabled.
Until this is fixed (in Vital?), this is how you can fix it (you have to do it each time you drag new Vital to Ableton’s track):

Right click on top bar of the Vital device in Ableton and make sure that “Enable MPE Mode” is NOT checked.

image

Also, check that your Ableton’s MIDI settings doesn’t have the MPE enabled for your MIDI in.