Not working on Linux: Libraries are not statically linked

Sorry to resurrect this old thread.

@Tytel Hi Matt, I’d love to work with Vital in Ardour on Linux, I wonder if you had time to look at the issue of statically link libsecret-1 within the Vital VST … Thanks again.


This is orthogonal to the issue at hand, it’s just a different means of distribution.

While you could include the relevant shared libraries in the flatpak, there will still be conflicts once loaded into the host where the ABI can conflict with other plugin or host libraries.

So either the plugin needs to be statically linked, or compiled with the same dependency stack as other plugins.

1 Like

Yea ok i think static linking is the best solution U-He dose this also and works perfect on all Distros i used :slight_smile: As a workaround on Fedora i currently using Vitalium

1 Like

It seems that the new beta pre-release (1.5.1) solved the library conflicts in Linux and now Vital loads fine in Ardour. Thanks @Tytel

1 Like

I installed the beta pre-release 1.5.5, and Ardour failed to detect Vital. I had to manually re-scan the plugin. A recent thread on the Ardour issue tracker points to this discussion.

I also tried installing Vital 1.0.7 and get the following errors in Ardour 7.1.0 on Ubuntu 22.04

[ERROR]: Could not load VST3 plugin '/usr/lib/vst3/Vital.vst3/Contents/x86_64-linux/': /lib/x86_64-linux-gnu/ undefined symbol: g_task_set_name
[WARNING]: Failed to add Synth Plugin to newly created track.
[ERROR]: Could not load VST2 plugin '/usr/lib/vst/': /lib/x86_64-linux-gnu/ undefined symbol: g_task_set_name
[ERROR]: LXVST: cannot load module from "/usr/lib/vst/"

My system has libsecret-1-0 version 0.20.5-2 installed.