AU/Logic - Clicking on some note starts


I’m running into a small issue where there seems to be some sort of “pre-click” about every 1/5 times I start transport on Logic 10.5.1 with Vital 1.0.7. This occurs most often straight off transport but also sometimes throughout the playing of a project after a small rest.

Here is the patch:
Video demonstration:

If you notice in the video sometimes there is a click which is visible on the waveform metering I currently have going. There is also a sidechain ducking the bass which helps make the click visible on the meter. I’ve confirmed the sidechain isn’t being triggered inconsistently and causing the clicking.


Hi @direct
I have Logic 10.5.1 and Vital 1.0.7, so I thought I’d look to try and replicate the click you observe. I created a simple 2 bar sequence and then bounced it. Here’s the audio. I don’t hear a click though. Would you expect to hear it in the scenario I’ve described above?

You’re correct that there is no click in that clip. However, I would say it is fairly obvious in the video I posted.

I took the patch, loaded it into a fresh project, routed the channel to a bus, and recorded the output and can confirm that the note appears to be starting early and abruptly, but only sometimes.
Screen Video:

Well, that is physically impossible, the sound can not actually start earlier then the MIDI. since you know…determinism.

But, most probably there is something wrong/odd with your latency compensation setting. This will move your audio after recording to align it with other tracks. Either Logic has the wrong setting there or Vital does not send the correct latency to Logic.

Is your MIDI quantized? Try with and without to see if it makes a difference, maybe Logic moves things around inconsistently…

Hi @direct

Yes, of course. I hear it load and clear.

I’ve tried to replicate your most recent post, and I don’t get the same behaviour.

I’m not sure there’s much more I can do to help find a solution. I’ll leave it to others (and perhaps @Tytel) to reach out.

Let me know if there’s any info around my setup / config that might help.

Thank you @andrew_a for spending the time testing on your system! I appreciate the diligence.

I’m not sure if this will happen consistently on your system as well, but I’ve found the most consistent way (yet) to induce this behavior is to prematurely stop transport before the note end.

Consistent replication on my system:

  1. New MIDI clip with a single long note.
  2. Start transport and stop before the note-off event.
  3. Start transport.

I think this is because Logic sends the MIDI CC #120 to Vital when transport is stopped.

I made a simple MIDI filter script in Logic’s Scripter plugin which seems to fix the issue on my system.

function HandleMIDI(event) {
  if (event instanceof NoteOn || event instanceof NoteOff) {

Although if I send a bunch of MIDI CC #120 events before turning on the script it seems a few notes will continue to click on my system.

Most importantly I’ve induced the behavior by sending MIDI CC #120 in Ableton:

Video Logic + Ableton:

Ableton .als (requires M4L)
Vital Click (1.0 MB)

I hope @Tytel can take a look at this when he gets a chance.

Ah! Very good find. So logic sends all notes off instead of individual note off messages, when transport is stopped. Interesting… Probably the envs in vital don’t reset properly then. should be able to test this as well tomorrow.

1 Like

I reported an issue around modulation not being reset on a “stop” in logic:

So I support this is related to the issue you’re experiencing re. logic and vital (?)

I’ll give this a go this evening and let you know.

I don’t get a consistent click, but I can replicate the click by moving from stop/start as you describe.